mirror of
https://github.com/Unkn0wnCat/dotfiles.git
synced 2025-05-01 10:56:20 +02:00
43 lines
1.5 KiB
Nix
43 lines
1.5 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
{
|
||
imports =
|
||
[ (modulesPath + "/profiles/qemu-guest.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "virtio_pci" "virtio_scsi" "sd_mod" "sr_mod" ];
|
||
boot.initrd.kernelModules = [ ];
|
||
boot.kernelModules = [ ];
|
||
boot.extraModulePackages = [ ];
|
||
|
||
fileSystems."/" =
|
||
{ device = "/dev/disk/by-uuid/9dc2f0f7-1080-476d-9967-e4e72fadffcc";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
fileSystems."/var" =
|
||
{ device = "/dev/disk/by-uuid/7d4df7b7-69be-4c52-a4d3-dc5048cc74b8";
|
||
fsType = "btrfs";
|
||
options = [ "subvol=@var" ];
|
||
};
|
||
|
||
fileSystems."/home" =
|
||
{ device = "/dev/disk/by-uuid/7d4df7b7-69be-4c52-a4d3-dc5048cc74b8";
|
||
fsType = "btrfs";
|
||
options = [ "subvol=@home" ];
|
||
};
|
||
|
||
swapDevices = [ ];
|
||
|
||
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
||
# (the default) this is the recommended approach. When using systemd-networkd it's
|
||
# still possible to use this option, but it's recommended to use it in conjunction
|
||
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
||
networking.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.ens18.useDHCP = lib.mkDefault true;
|
||
|
||
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
||
}
|